Arduino Blink Example Not Working – FPGA Output Dead?

Forums Forums Getting Started with XLR8 Arduino Blink Example Not Working – FPGA Output Dead?

This topic contains 0 replies, has 1 voice, and was last updated by  JC_LogicDesign 2 months, 1 week ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #2314

    JC_LogicDesign
    Participant

    I received an XLR8 board at an Altera training session last March. I decided to experiment with it some more and started with the Arduino blink example to make sure everything was communicating fine. Well, it did not work. Other I/O seem fine, but D13 will not toggle (thus the LED does not blink). I downloaded the schematic and board files to track down the routing of this signal. It appears that the pin 1 input to Q7 is not toggling when I examine it with an oscilloscope. Is pin M11 on the FPGA cooked?

    To be honest, I’m not sure D13 ever worked. Have there been any reports of issues between the level shifters and the FPGA I/O?

    I did verify that the LFSR example (from the XLR8 training) still worked and I was also able to toggle D12 and read it via D11 with a jumper. Everything seems fine except for D13. Configuring D13 as an input results in always reading a 0.

    My XLR8 board is Rev 2.2 with a build date of 02.2016.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.